User talk:AdamV2

From MechWarrior Online Wiki mechwarrior online, mwo, mech game, mwo wiki, mech online,
Jump to: navigation, search

Archive[edit source]

Random Deletion[edit source]

Can you avoid random deletion of the user pages of others Seth, especially without providing a reason for punting placeholders arbitrarily? If not, your own is a valid candidate. NDA pretty much prevents anything but placeholders or filler which just relates to wiki or previous titles. Grow some standards and publish them. --Insidious Johnson

Which page did I delete? The only pages I have intentionally deleted are ones that appear to be spam or I have edited out information that only beta testers can know. If it was a user page, then I probably thought it was spam.--Seth 16:38, 1 October 2012 (CDT)

I dont understand why you are deleting Random people's units. You deleted my Karaian Empire page because of inactivity? We play MWO every night wtf?

Calm your storm! I've restored Unit:Karaian Empire. It's no trouble to restore a page that didn't need to be deleted. The reason why it was deleted is because it didn't have a link to a unit website, so it wasn't doing potential new players looking for a unit to play with any good, which is the whole point of this directory. There was a tag on the page for over a month (on there now) that asked the author of the page to update it with a url or we would assume it was just another unit that had disbanded. Checking back, it looks like you had removed the link to a mektek forum thread late last December. I periodically go through and try to clean out pages that don't have a logo or url because there are a number of people who create unit pages and only half fill them out. Before I started cleaning out some of those old pages, there were roughly 300 unit listing pages, 70-80 of those were incomplete and hadn't been updated in months. --Seth (talk) 01:26, 12 March 2013 (UTC)

Ok sorry, I thought it was gone for good, hence my angst. I am the author and have neglected the page I agree. Can you also relist us in the Mechwarrior Online unit database page. Our unit doesnt seem to be showing up. Thank you for the quick response.

I just checked and it is listed in the Category:MechWarrior Online Units page and the MechWarrior Online Mercenary Player Units list. I had to press refresh next to the watch button to refresh the cache. I do need to figure out a way to better sort the list of all online units given how many are on there now.--Seth (talk) 04:14, 12 March 2013 (UTC)

error[edit source]

had some errors while trying to change some of the pages. left one of the bug reports from the stk pages on stk-5S page.--Peckham33 talk Help is always given to those who ask for it 21:54, 12 March 2013 (UTC)

You might have been updating pages too rapidly. I couldn't even keep up. I'll keep any eye out for similar faults in the future.--Seth (talk) 22:04, 12 March 2013 (UTC)
I tried going slowly and 1 at a time as soon as I saw the errors and was still getting the errors. Also, I have gone a lot faster without errors.

PS: I go so fast by editing multiple pages at one time so that I can edit while the other pages are loading and saving.--Peckham33 talk Help is always given to those who ask for it 22:21, 12 March 2013 (UTC)

Getting the errors again when I grab mechs from http://mwowiki.org/wiki/Special:WhatLinksHere/Template:Mech_Model and try to change them over.
Invalid marker: ?UNIQ197bb4e26260822a-section-00000009-QINU?

Backtrace:

#0 /home/mwowiki/public_html/includes/parser/StripState.php(40): StripState->addItem('general', '?UNIQ197bb4e262...', '<section begin=...')
#1 /home/mwowiki/public_html/includes/parser/Parser.php(3782): StripState->addGeneral('?UNIQ197bb4e262...', '<section begin=...')
#2 /home/mwowiki/public_html/includes/parser/Preprocessor_DOM.php(1110): Parser->extensionSubstitution(Array, Object(PPFrame_DOM))
#3 /home/mwowiki/public_html/includes/parser/Parser.php(4177): PPFrame_DOM->expand(Object(PPNode_DOM), 27)
#4 /home/mwowiki/public_html/includes/parser/Parser.php(1124): Parser->formatHeadings('<table class="w...', '{| class="warni...', true)
#5 /home/mwowiki/public_html/includes/parser/Parser.php(345): Parser->internalParse('{| class="warni...')
#6 /home/mwowiki/public_html/includes/WikiPage.php(1522): Parser->parse('{| class="warni...', Object(Title), Object(ParserOptions), true, true, NULL)
#7 [internal function]: WikiPage->prepareTextForEdit('{| class="warni...')
#8 /home/mwowiki/public_html/includes/Article.php(1783): call_user_func_array(Array, Array)
#9 /home/mwowiki/public_html/extensions/SpamBlacklist/SpamBlacklist_body.php(50): Article->__call('prepareTextForE...', Array)
#10 /home/mwowiki/public_html/extensions/SpamBlacklist/SpamBlacklist_body.php(50): Article->prepareTextForEdit('{| class="warni...')
#11 /home/mwowiki/public_html/extensions/SpamBlacklist/SpamBlacklistHooks.php(27): SpamBlacklist->filter(Object(Title), '{| class="warni...', '', '', Object(EditPage))
#12 [internal function]: SpamBlacklistHooks::filterMerged(Object(EditPage), '{| class="warni...', '', '')
#13 /home/mwowiki/public_html/includes/Hooks.php(216): call_user_func_array('SpamBlacklistHo...', Array)
#14 /home/mwowiki/public_html/includes/GlobalFunctions.php(3856): Hooks::run('EditFilterMerge...', Array)
#15 /home/mwowiki/public_html/includes/EditPage.php(1330): wfRunHooks('EditFilterMerge...', Array)
#16 /home/mwowiki/public_html/includes/EditPage.php(960): EditPage->internalAttemptSave(false, false)
#17 /home/mwowiki/public_html/includes/EditPage.php(357): EditPage->attemptSave()
#18 /home/mwowiki/public_html/includes/actions/EditAction.php(51): EditPage->edit()
#19 /home/mwowiki/public_html/includes/actions/EditAction.php(71): EditAction->show()
#20 /home/mwowiki/public_html/includes/Wiki.php(484): SubmitAction->show()
#21 /home/mwowiki/public_html/includes/Wiki.php(278): MediaWiki->performAction(Object(Article))
#22 /home/mwowiki/public_html/includes/Wiki.php(593): MediaWiki->performRequest()
#23 /home/mwowiki/public_html/includes/Wiki.php(503): MediaWiki->main()
#24 /home/mwowiki/public_html/index.php(58): MediaWiki->run()
#25 {main}


Invalid marker: ?UNIQe5b0c067fe78aa6-section-00000009-QINU?

Backtrace:

#0 /home/mwowiki/public_html/includes/parser/StripState.php(40): StripState->addItem('general', '?UNIQe5b0c067fe...', '<section begin=...')
#1 /home/mwowiki/public_html/includes/parser/Parser.php(3782): StripState->addGeneral('?UNIQe5b0c067fe...', '<section begin=...')
#2 /home/mwowiki/public_html/includes/parser/Preprocessor_DOM.php(1110): Parser->extensionSubstitution(Array, Object(PPFrame_DOM))
#3 /home/mwowiki/public_html/includes/parser/Parser.php(4177): PPFrame_DOM->expand(Object(PPNode_DOM), 27)
#4 /home/mwowiki/public_html/includes/parser/Parser.php(1124): Parser->formatHeadings('?<table style="...', '{{Infoboxmodel?...', true)
#5 /home/mwowiki/public_html/includes/parser/Parser.php(345): Parser->internalParse('{{Infoboxmodel?...')
#6 /home/mwowiki/public_html/includes/EditPage.php(2600): Parser->parse('{{Infoboxmodel?...', Object(Title), Object(ParserOptions))
#7 /home/mwowiki/public_html/includes/EditPage.php(1724): EditPage->getPreviewText()
#8 /home/mwowiki/public_html/includes/EditPage.php(379): EditPage->showEditForm()
#9 /home/mwowiki/public_html/includes/actions/EditAction.php(51): EditPage->edit()
#10 /home/mwowiki/public_html/includes/actions/EditAction.php(71): EditAction->show()
#11 /home/mwowiki/public_html/includes/Wiki.php(484): SubmitAction->show()
#12 /home/mwowiki/public_html/includes/Wiki.php(278): MediaWiki->performAction(Object(Article))
#13 /home/mwowiki/public_html/includes/Wiki.php(593): MediaWiki->performRequest()
#14 /home/mwowiki/public_html/includes/Wiki.php(503): MediaWiki->main()
#15 /home/mwowiki/public_html/index.php(58): MediaWiki->run()
#16 {main}

--Peckham33 talk Help is always given to those who ask for it 22:35, 12 March 2013 (UTC)

I have a feeling we were both doing the same thing in opening multiple windows and editing them simultaneously. Try opening one of the pages from that list and changing the template and avoid one of the playable 'Mechs who's templates I have already updated.--Seth (talk) 23:18, 12 March 2013 (UTC)
editing only 1 page at a time I still get the error.
Invalid marker: ?UNIQ59e18991964211e-section-00000009-QINU?

Backtrace:

#0 /home/mwowiki/public_html/includes/parser/StripState.php(40): StripState->addItem('general', '?UNIQ59e1899196...', '<section begin=...')
#1 /home/mwowiki/public_html/includes/parser/Parser.php(3782): StripState->addGeneral('?UNIQ59e1899196...', '<section begin=...')
#2 /home/mwowiki/public_html/includes/parser/Preprocessor_DOM.php(1110): Parser->extensionSubstitution(Array, Object(PPFrame_DOM))
#3 /home/mwowiki/public_html/includes/parser/Parser.php(4177): PPFrame_DOM->expand(Object(PPNode_DOM), 27)
#4 /home/mwowiki/public_html/includes/parser/Parser.php(1124): Parser->formatHeadings('<table class="w...', '{| class="warni...', true)
#5 /home/mwowiki/public_html/includes/parser/Parser.php(345): Parser->internalParse('{| class="warni...')
#6 /home/mwowiki/public_html/includes/WikiPage.php(1522): Parser->parse('{| class="warni...', Object(Title), Object(ParserOptions), true, true, NULL)
#7 [internal function]: WikiPage->prepareTextForEdit('{| class="warni...')
#8 /home/mwowiki/public_html/includes/Article.php(1783): call_user_func_array(Array, Array)
#9 /home/mwowiki/public_html/extensions/SpamBlacklist/SpamBlacklist_body.php(50): Article->__call('prepareTextForE...', Array)
#10 /home/mwowiki/public_html/extensions/SpamBlacklist/SpamBlacklist_body.php(50): Article->prepareTextForEdit('{| class="warni...')
#11 /home/mwowiki/public_html/extensions/SpamBlacklist/SpamBlacklistHooks.php(27): SpamBlacklist->filter(Object(Title), '{| class="warni...', '', '', Object(EditPage))
#12 [internal function]: SpamBlacklistHooks::filterMerged(Object(EditPage), '{| class="warni...', '', '')
#13 /home/mwowiki/public_html/includes/Hooks.php(216): call_user_func_array('SpamBlacklistHo...', Array)
#14 /home/mwowiki/public_html/includes/GlobalFunctions.php(3856): Hooks::run('EditFilterMerge...', Array)
#15 /home/mwowiki/public_html/includes/EditPage.php(1330): wfRunHooks('EditFilterMerge...', Array)
#16 /home/mwowiki/public_html/includes/EditPage.php(960): EditPage->internalAttemptSave(false, false)
#17 /home/mwowiki/public_html/includes/EditPage.php(357): EditPage->attemptSave()
#18 /home/mwowiki/public_html/includes/actions/EditAction.php(51): EditPage->edit()
#19 /home/mwowiki/public_html/includes/actions/EditAction.php(71): EditAction->show()
#20 /home/mwowiki/public_html/includes/Wiki.php(484): SubmitAction->show()
#21 /home/mwowiki/public_html/includes/Wiki.php(278): MediaWiki->performAction(Object(Article))
#22 /home/mwowiki/public_html/includes/Wiki.php(593): MediaWiki->performRequest()
#23 /home/mwowiki/public_html/includes/Wiki.php(503): MediaWiki->main()
#24 /home/mwowiki/public_html/index.php(58): MediaWiki->run()
#25 {main}

--Peckham33 talk Help is always given to those who ask for it 23:34, 12 March 2013 (UTC)

Site notice[edit source]

Do we need the site notice saying we will do what we did on a date that has passed anymore? Peckham33 talk Help is always given to those who ask for it 16:23, 4 May 2013 (UTC)

Heya[edit source]

Aye, I see now where the 'Mech images are on the official website, will use those from now on, sorry about that. As for the XML, I haven't had too much experience with XML files and Wikis, though I do have some experience with XML and other scripts, I'll start poking at it, see if I can't come up with something useful. --Ten19 (talk) 19:56, 18 June 2013 (UTC)

AdamV2?[edit source]

We could really use your help on a couple of things on the Admin Noticeboard, such as updating the templates to use the new module system, and fixing the "futher results..." listing for the Medium BattleMechs on the BattleMechs page. You created these templates and nobody else seems to know how to do these more complicated fixes. I know I don't. If you get this, I'd be happy to go into more details. --Trifler500 (talk) 00:28, 25 September 2014 (UTC)

Sorry, my userpage was poking me at an old email. Fixed that now. Let me know what you need help with.--AdamV2 (talk) 22:10, 29 September 2014 (UTC)
Cool. Glad you're still kicking. :)
Problem 1: MWO has completely changed the module system, and we need the Infoboxmodel template updated to reflect the changes to Module Slots. We may want to remove Modules from the BattleMech Hardpoints List entirely and just list them under the individual 'mech pages in the Overview box. Either way, I wasn't able to figure out how to change it without messing something up.
Problem 2: If you look at the BattleMechs list and click on "further results..." under the Medium mechs, the user gets a table of completely messed up data. It displays HTML code inside the table. On the Admin Noticeboard, MeepSire said it appears to be caused by the interaction of two different templates. I was wondering if the BattleMech Hardpoints list could be made to just display as many as necessary and eliminate the need for a "further results..." page entirely.
Of less importance, I've been wondering if someone could please explain the process for obtaining 'mech images for uploading. I've noticed that the older 'mechs have nice large images that are displayed lower so they don't block the 'mech name in the Overview box. The newer 'mechs have images that are dead center rather than lower, so they do block the 'mech name. They're also smaller. It seems like different people were using different methods of obtaining the images, and nobody has done it as well as whoever did the first ones. Not only would I like to know the best method of obtaining the images, but I'd like to list the process on a "how-to" page of some kind (do we have one?) so that it's available to everyone. --Trifler500 (talk) 01:25, 30 September 2014 (UTC)
I increased the limit of how many 'Mechs are displayed in each weight class to 1000, so the further results won't appear now. I used to get the images from MWO's BattleMech page. However, they haven't updated that since before the Clans came out. I can still pull them off of smurfy, but those are the smaller images you're referring to. I don't have a good answer as to where to get those images from. I imagine they must be in the game files somewhere. That Infoboxmodel area with the tabs was always a notorious PIA to work with. The styling of it can't be changed without contacting someone from Cursed. I honestly think it should just be replaced with a different infobox and the info from the other tabs displayed elsewhere on each page. I'll have time for that Friday maybe. On a separate note, I would like to make you an admin on here. You've contributed quite a bit and I think you're very motivated to contribute to this project. Let me know.--AdamV2 (talk) 04:16, 30 September 2014 (UTC)
That sounds great. Thanks!
Currently my plan is to continue adding Clan 'mech pages as they become available for credits. --Trifler500 (talk) 02:29, 1 October 2014 (UTC)
I updated the infobox to include the new module sections. I also got rid of the table of contents since it pushed the actual content down without really being necessary. Mech pages will need to have the correct number of modules listed on their pages IF they have a number different than the normal 1/2/2 (1 Mech Module, 2 Weapon Modules, 2 Consumable Modules) by default. To do so, replace the line:
|module slots = 
with:
|mech module slots = # |weapon module slots = # |consumable module slots = #
where # equals the correct number of module slots on that 'Mech. A full list can be found here.--AdamV2 (talk) 22:19, 3 October 2014 (UTC)
Excellent! I'll start updating. --Trifler500 (talk) 23:41, 3 October 2014 (UTC)
Hmm... I think you may want to make it not default to 1/2/2 because we can't tell if someone made a mistake entering the info or even if the module info was never entered at all. Having it leave the cell empty might be a better way to go.
Also, would it be hard to do something like this?:
|module slots = #|#|#
Where the first # is the mech module slots, second is weapon module slots, and third is consumables slots. It would just be a little more convenient for data entry is all. --Trifler500 (talk) 00:01, 4 October 2014 (UTC)
Each module type needs it's own space since each is a separate property of those 'Mechs. For example, if I wanted, I could create a list that would sort 'Mechs from those that have the most module slots (mech module slots + weapon module slots + consumable module slots) down to those with the fewest. It's similar to why each section of the 'Mech has a space to list how many energy, ballistic, and missile weapons. It's a bit more cumbersome for the page editor, but necessary to sort the properties of the 'Mech. I went with 1/2/2 since that was the most common combination of modules and would require the least amount of work to update on the wiki. The Smurfy page lists which models have a different number of modules. If you prefer, though, I can set the default to blank. --AdamV2 (talk) 04:34, 4 October 2014 (UTC)
Yeah, I'd prefer the default be blank so we can more easily spot mistakes. Thanks. --Trifler500 (talk) 07:00, 4 October 2014 (UTC)

Mech Images[edit source]

I've been messing with it some and it appears that the reason a lot of the 'mechs are so small is because their image is wider. For example, the Jenner image is tall and narrow, and it displays beautifully. The Kit Fox, however, is tiny. I tried cropping the unnecessary white space off the sides of the Griffin GRF-1N image, and it did indeed display it larger in the Overview box, but unfortunately it lost the transparency when I re-saved it, so I undid my changes. So narrower = bigger in the Overview box, but I don't know how to edit the file without losing the transparency. My web search didn't turn up anything useful. Maybe a program like Photoshop could do it, but I don't have it. --Trifler500 (talk) 23:07, 2 October 2014 (UTC)

I don't know what program you used to crop the image. I don't know if MS Paint will preserve transparencies. You can upload them to imgur and use the edit tools there to crop the images. I tested it with the Griffin image to be sure.--AdamV2 (talk) 04:48, 3 October 2014 (UTC)
Ok, thanks. Main thing was I wanted to share the reason for the "smallness" with you since you said you were thinking about redesigning the Overview box. Unless you already knew of course. ...and yeah, I was using Paint. --Trifler500 (talk) 05:11, 3 October 2014 (UTC)
You were asking about better quality images. These should work well: [1] --AdamV2 (talk) 05:13, 16 October 2014 (UTC)
Cool, thanks. Unfortunately they still have the same sizing issue, but I uploaded this higher resolution version for the Boar's Head and I uploaded an example image for the Founders, Phoenix, and Revival pages. --Trifler500 (talk) 06:46, 18 October 2014 (UTC)

Just now I started wondering if it's possible to adjust the template for the Overview box to add one or two line breaks before it displays the 'mech image. I tried just adding
but it saw it as a part of the file name. If it's possible, that should eliminate the problem of the 'mech covering up the model name. --Trifler500 (talk) 07:07, 27 October 2014 (UTC)

That was an intentional style choice on my part. I've changed it so that the image isn't pulled up on top of the name anymore. It was done though in-line styling, specifically this line:
style="position:relative;left:0px;top:0px; width:170px; font-weight:bold; float:left; line-height:20px; font-size:36px; transform:scale(1,2.5); -moz-transform:scale(1,2.5); -webkit-transform:scale(1,2.5); -ms-transform:scale(1,2.5); -o-transform:scale(1,2.5); margin-top:35px; margin-bottom:0px; z-index:1; color:yellow;"
I had set "margin-bottom:" to "-25px;". Now it's set to 0px. There is still some overlay, and that is because of the "transform:". The normal font used by the 'Mech names is thick and wide. The transform line make it 2.5X taller than normal. You can remove any overlay of the image by changing the margin-bottom to 20px or so to push the image down. --AdamV2 (talk) 19:38, 27 October 2014 (UTC)
Awesome, thanks. That appears to have fixed all of the problem ones and all of the ones I checked look much better now. --Trifler500 (talk) 23:41, 27 October 2014 (UTC)

Module Slots[edit source]

Maybe you just haven't had a chance to finish yet, but the Infobox BattleMech template isn't working properly. I know you did something earlier after I unsuccessfully tried to edit it. After you did that, the first variant started being displayed correctly (see Locust as an example), but the second variant won't display the Consumable Module slots for some reason. Also, none of the variants after the second display modules at all. At first I thought it was just because you didn't update the rest of them, but when I tried duplicating what you did on the first variant to the other variants, it just displayed errors.

I've finished updating all of the 'mechs, so you can go ahead and update the Modules column on the BattleMech Hardpoint List to display #/#/#. A tooltip when the cursor is hovered over the word "Modules" at in the header that says "Mech/Weapon/Consumable" would be helpful too, if that's not too hard to do. I noticed that Smurfy's has quite a few tooltips, so it gave me the idea. --Trifler500 (talk) 22:13, 10 October 2014 (UTC)

For the InfoboxBattleMech, I forgot to update the subsequent 7 result formats. It's been a while since I've done much on here, and I'm a bit rusty. Why did I make this stuff so complicated?! Actually, the reason I did that was updating information on multiple pages could be done by editing just one page. I added separate columns to the BattleMech Hardpoint List. I can't add a mouse over to that table because it really is just a result table. I would need to make a template for the results in order to have a mouse over like I did for the Twist X bonus number in the Infoboxmodel template. --AdamV2 (talk) 22:51, 10 October 2014 (UTC)
Those columns on the Hardpoints table are extremely wide... but thanks for fixing that stuff. :) --Trifler500 (talk) 05:54, 12 October 2014 (UTC)
Well, if you're feeling adventurous, you can look to how I made the hardpoints table for the individual 'Mech pages (Jenner JR7-D for example) to see how to redo the hardpoints list.
{{#ask: [[Category:{{{mech|}}}]] | [[Category:Playable]] <!-- Limits your query to certain categories. You would likely want to limit it to playable Mechs and one of the weight classes-->
|?Jump Jets <!-- This is where you enter the properties of the 'Mech you want to display. This list should work well-->
|?Mech Module Slots
|?Weapon Module Slots
|?Consumable Module Slots
|?AMS
|?Right arm
|?Right torso
|?Head
|?Center torso
|?Left torso
|?Left arm
|?Total Hardpoints
| limit=500 <!-- You can limit the query to a certain number. You'll probably want to increase this number-->
| format= template <!-- Instead of format=table like I currently have, this is telling the query you want it to use the layout of a template -->
| template= Query Mech Specs 2 <!-- This is the name of the template you want the query to use. In the template, you use {{{#}}} as a place holder for the property you asked for. They go in numerical order. In this case {{{1}}}="Jump Jets" down through {{{12}}} which equals "Total Hardpoints".
| sort= Tonnage <!-- This is the property you want the query to sort your list by -->
| order= asc <!-- The order you want them to display in -->
| introtemplate= Mech Specs Header2 <!-- This is the template that your table will use as a header. Here you'll put the names of the columns-->
| outrotemplate= Mech Specs Footer <!-- Not really necessary unless you want to put something at the bottom of your table -->
}}
You can copy and paste that query code into a blank page to start playing with it. You'll need to create the new template pages for it to use. You can look at the ones this query is referencing for an example of how it works. Good luck!--AdamV2 (talk) 06:34, 13 October 2014 (UTC)

Mech Forums[edit source]

The MechSpecs forums changed to include the name of the 'mech in addition to having the identification number. I suspect if it added "forums/as7-k.167" after www.mechspecs.com instead of just "167" as it used to, then it would work again, but of course I haven't tested it. --Trifler500 (talk) 06:46, 18 October 2014 (UTC)

Krivvan's Changes[edit source]

It looks like a user named Krivvan has come along and completely deleted the Template:Infobox BattleMech and has started going through and making major changes all over the place. Is he an admin I just haven't seen before or is he some new user who's just decided to go nuts on the existing setup? --Trifler500 (talk) 11:44, 14 January 2015 (UTC)

References Tag Corruption?[edit source]

A weird thing is happening that was brought to my attention by the user RevancheRM. It appears that everywhere on this wiki where the <references/> tag is used, it's automatically being turned into "UNIQ48f984eb77b76688-references-00000007-QINU?". It also displays that text on the page. You can see an example on the Command Console page. I can edit it to delete that weird text and type in a references tag and it displays fine in the preview, but it just changes into that weird text as soon as I save it. I checked in using a different browser to make sure it wasn't a browser problem and it happens in both Internet Explorer and Firefox. Any ideas what might be causing it? --Trifler500 (talk) 16:26, 9 February 2015 (UTC)

Template Include Size Exceeded[edit source]

We desperately need someone to fix the "Pages where template include size is exceeded" problem. I don't know how, and the Hardpoints Table template on the BattleMechs page is failing to display listings at random. It wasn't too bad before, but as I add more 'Mechs, it gets worse and worse. After the last big batch, it seems really bad. People are going to have problems finding what they're looking for. Breaking the Hardpoints Table template up so that there's a separate template for each 'Mech class might take care of it. --Trifler500 (talk) 01:20, 2 August 2015 (UTC)

Is it the chassis comparison table? --AdamV2 (talk) 06:53, 4 August 2015 (UTC)
It's the one that comes up when you click on the BattleMechs link just beneath the Main Page link on the left. If I click on the Edit button it says "Template:Hardpoints Table". --Trifler500 (talk) 07:57, 4 August 2015 (UTC)
I'm looking at Category:Playable, but I'm not seeing an error. Can you link the specific page for me?--AdamV2 (talk) 21:15, 7 August 2015 (UTC)
I can click on any 'Mech on that list, and it displays the error under the categories associated with that page. Vindicator VND-1AA is one example. However, pages like the Vindicator page do not have the error. --Trifler500 (talk) 01:19, 8 August 2015 (UTC)
Any luck? In addition to that problem with pages not showing up on the list, now pages like Atlas aren't displaying correctly anymore. I have no idea what's going on. :( If you can't fix it then this wiki is probably dead because there's nobody else I can ask who knows how to work with templates of this complexity. --Trifler500 (talk) 23:40, 18 August 2015 (UTC)
I tried to fix the limit, but it looks like that's a limitation of the wiki software. Looks like the problem with the Atlas page lies in the Infobox BattleMech template. That I'm sure I can fix.--AdamV2 (talk) 06:40, 19 August 2015 (UTC)
I had to dump the tabbed box (was a long time coming, really) and replace it with the look it has now. I simplified the infoboxes on the general 'Mech pages because there didn't need to be that much info.--AdamV2 (talk) 07:44, 19 August 2015 (UTC)
Ok, that works. :) Going back to the BattleMech Hardpoint List, since it's a limitation of the wiki software, then I guess the only way to fix it is to revamp it so it can list the 'Mechs without using a template? Maybe turn it into a regular table? If you think that's a good idea, I could start building a table to display on the Category:Playable page (BattleMechs link in the upper left corner). --Trifler500 (talk) 08:03, 19 August 2015 (UTC)
That's a lot of work, though. The advantage of the current template is that as soon as the 'Mech pages are created, the template is automatically updated too. Turning it into a table doubles the work that needs to be done for every future 'Mech. It's possible that the templates could be split into smaller sections than just weight classes.--AdamV2 (talk) 04:20, 20 August 2015 (UTC)
Yeah, that would indeed be better, but it does have to allow for ongoing expansion. I'm not sure if I mentioned it, but they're adding another 36 'Mech variants just in the next six months or so. Would it help to list the weight classes separately, rather than all of them in the same giant list as it does now? For instance one template could generate a table for Assault, then a separate template could generate a separate table for Heavy, listed beneath the first, etc. Right now it appears that a single template is handling all of them. --Trifler500 (talk) 06:02, 20 August 2015 (UTC)
The hardpoint list and chassis attributes table templates have four templates inside to handle each weight class. Templates within templates. Now the question is, would it even fix the problem if the results are pulled up a different way if the end total results are the same.--AdamV2 (talk) 06:11, 20 August 2015 (UTC)
Having that one template call four other templates might mean (according to the wiki software) that it has to store the data from all four. Then again it might not... Ok, I just ran a test to have it display just the Lights and it still only displays two of the five Spiders for me, so maybe that won't help. :(
- BTW, did you remove all of the non-variant 'Mech pages from the list (Atlas, Awesome, etc.) or is that just another symptom of whatever's going on? For the last couple of days it has been displaying variant pages only. --Trifler500 (talk) 07:41, 20 August 2015 (UTC)
I see the full list down through the Urbies with no problem. I don't think the non-model pages were supposed to be included in the hardpoint lists.--AdamV2 (talk) 17:52, 20 August 2015 (UTC)
Yeah, they were always there and they were nice to have. Otherwise, people never see them at all, and they divide each 'Mech up nicely on the list. I definitely like having the non-model pages on there. As for random missing model pages, how can you be sure you see every single model on the list? That's the symptom I've been talking about that the template size exceeded has been causing. It's gotten worse and worse as I've added more models over time. I still only show two Spider variants in both Firefox and Internet Explorer. --Trifler500 (talk) 23:29, 20 August 2015 (UTC)
Ah, now I see. It looks like those pages needed to be refreshed. I'm seeing the same issue with the Jenner and Raven, too. I'm gonna try running the update data function from the admin control panel. Hopefully that'll take care of that so manually refreshing all those pages won't be necessary. As far as adding the plain 'Mech names to the hardpoint tables, I don't think they were ever there. The way query works is by looking for pages in specific categories. The Mech and individual model pages never shared the same categories, so they wouldn't ever appear on that list. They could be added to the list by adding the categories "Light BattleMechs" and "Playable" to the all the light Mech pages like Jenner, Firestarter, Mist Lynx, ect...--AdamV2 (talk) 11:00, 21 August 2015 (UTC)
Running out of screen space here. :) As of three days ago, the non-variant pages were showing up on that list, and have been for the past several years. It should display, for example, Atlas ,then Atlas AS7-BH beneath that, and the rest of the Atlas variants. Then it would have Awesome, and the Awesome variants beneath that. They've always been there. --Trifler500 (talk) 11:15, 21 August 2015 (UTC)
Any ideas on either of those problems (Variants not being displayed, non-variant pages not showing up?). The former definitely seems to be connected to the template exceeded issue. Today the Spiders are all there, but only two Hunchback variants show up for me. It may be different for each computer that accesses it. --Trifler500 (talk) 23:43, 24 August 2015 (UTC)
Just gonna start a new line here. I already found the problem with the Mechs not showing up. That refresh function I mentioned in my last post is still running and is 58% complete. The reasons the Spiders are showing up is because I went to those pages and ran the refresh function on them specifically. That could be done for all the Mechs not showing up right now, but I wanted to try the automatic function first. I didn't think it would take this long, though. As far as getting the general Mech pages to show up on that list, you would have to add them to the categories that are being queried like I mentioned in my previous post.--AdamV2 (talk) 15:37, 26 August 2015 (UTC)
Ok. That's good to know what's causing the missing Mechs. That also makes sense that as I add more and more Mechs it would take make the refresh function take longer and longer, which explains why it's been getting worse as more are added. It's actually been happening for over a year, but perhaps you've just been running refresh functions from time to time. Sorry I missed that last part in your previous post. I'll try adding those. --Trifler500 (talk) 00:52, 27 August 2015 (UTC)
Well... all of the light 'Mechs showed up find when I added just the "Playable" category. However, none of the three assault 'Mechs I added it to showed up, so I also tried added the "Assault BattleMechs" category to the Atlas page and it still doesn't show up. I waited several days to see if it just needed time to update, but there's no change. I added the "Playable" category to several medium 'Mechs and some of them showed up and some didn't. I'm rather confused by the lack of consistency. --Trifler500 (talk) 00:33, 2 September 2015 (UTC)
If you take a look at the query for the harpoint list, you would find this part that deals with listing all of the assault 'Mechs.
{{#ask: [[Category:Assault BattleMechs]][[Category:Playable]]
|format=broadtable
|mainlabel=BattleMech
|limit=1000
|?tonnage=Weight
|?Right arm=RA
|?Right torso=RT
|?Head=HD
|?Center torso=CT
|?Left torso=LT
|?Left arm=LA
|?Total Hardpoints=Total
|?Jump Jets = JJ
|?Mech Module Slots=Mech<br>Module
|?Weapon Module Slots=Weap<br>Module
|?Consumable Module Slots=Cons<br>Module
|?ECM
}}
That first line deals specifically with what pages in the wiki that the query is looking for. On the first line, you see that it is searching only in pages that are included in both the Assault BattleMechs and Playable categories. On the Atlas page, it looked like you tried to correctly add it to the Category:Assault BattleMechs category, but just left a link to the Assault BattleMechs page because you forgot to add the "Category:" part inside the brackets. I added it to the Atlas page, and it shows up in the list correctly now.--AdamV2 (talk) 01:25, 2 September 2015 (UTC)
Oops. I should have noticed the missing "Category:" part. :P Regarding the query, why do the light 'Mechs work with just the "Playable" category then?
Gotta have both for the Light 'Mechs too. But if you look at the 35 ton category on the Adder page, you see that category is categorized itself as under Light BattleMechs. However, if you look at the Atlas page, the 100 tons category is not categorized under the Assault BattleMechs. Adding the 80-100 tons categories to the Assault BattleMechs categories might be a faster way of adding them to the hardpoint list.
Ah, thank you! Those last two sentences were exactly what I needed to finally understand why some worked and some didn't. I believe I have all of the non-variant pages showing up again now. --Trifler500 (talk) 05:36, 3 September 2015 (UTC)

Duplicate Listings[edit source]

I'm afraid that I'm stumped again. On the table of playable BattleMechs (Category:Playable), it's listing the Wolfhound WLF-1B under both Medium and Light 'Mechs. Even odder is that it's just that one variant that shows up in the Mediums. Just recently I added the Jenner IIC and three variants are showing up under Heavy, Medium, and Light 'Mechs. Some of them were automatically added to a category called "Pages using duplicate arguments in template calls", but not all of them. I haven't been able to figure out what's causing that either. --Trifler500 (talk) 07:49, 20 February 2016 (UTC)

Hello? --Trifler500 (talk) 02:07, 13 March 2016 (UTC)
FYI I've started just deleting the template at the bottom of individual 'Mech pages since that has been eliminating the duplicates. Unfortunately I don't know how to actually fix the template so that's the best I can do at this point. --Trifler500 (talk) 05:18, 24 April 2016 (UTC)

Introducing myself as the new Wiki Manager[edit source]

Hi, this is just to let you know that I am taking over as your Wiki Manager. Feel free to contact me if you need anything.